Notion Status

Investigating reports of unexpected updates to person properties

Incident Report for Notion

Resolved

Our engineering team has deployed a fix and this incident has been resolved.
Posted Oct 31, 2025 - 04:41 PDT

Identified

The issue has been identified by our engineering team and fix is being implemented
Posted Oct 31, 2025 - 01:30 PDT

Investigating

We’re looking into reports of unexpected updates to person properties in databases.
Posted Oct 30, 2025 - 22:48 PDT
This incident affected: Core Services (Databases).