Notion Status

Notion access issues in Switzerland

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Aug 16, 2025 - 10:10 PDT

Identified

Users in Switzerland may be experiencing issues accessing Notion. Our engineering team has identified the issue and working with the local ISP to address the issue.

For users impacted, please try changing your DNS to a public one like 8.8.8.8 or 1.1.1.1 as this might resolve the issue. You can learn more about how to do this in the below link;

https://developers.google.com/speed/public-dns/docs/using
Posted Aug 15, 2025 - 22:18 PDT

Investigating

Users in Switzerland may be experiencing issues accessing Notion. Our engineering team is currently working to resolve this problem.
Posted Aug 15, 2025 - 05:44 PDT
This incident affected: Core Services (Login and user accounts, View and edit content, Databases, Search).