Notion Status

Notion Calendar down

Incident Report for Notion

Resolved

Our engineering team has rolled out a fix and the issue is now resolved.
Posted Jul 22, 2025 - 03:25 PDT

Investigating

Some users are unable to load Notion Calendar on web and desktop apps. We're currently investigating
Posted Jul 22, 2025 - 02:52 PDT
This incident affected: Notion Calendar.