Notion Status

Some Users are Unable to Access Notion

Incident Report for Notion

Resolved

A small number of users may have experienced higher latency or intermittent failures. This has now been resolved.
Posted Feb 25, 2026 - 19:31 PST

Investigating

Some users may experience issues when accessing Notion.
Our engineers are actively investigating this issue.
Posted Feb 25, 2026 - 17:35 PST