Notion Status

HEIC images failing to load

Incident Report for Notion

Resolved

This incident is now resolved.
Posted Mar 03, 2026 - 10:01 PST

Investigating

We’re investigating an issue where HEIC images aren’t loading properly in Notion. Our team has identified the likely cause and is actively working on a fix. In the meantime, you may notice some HEIC images failing to display or appearing stuck loading.
Posted Mar 03, 2026 - 08:52 PST
This incident affected: Notion API.