Notion Status

Notion-GCP Partial Outage

Incident Report for Notion

Resolved

The earlier issue impacting Notion’s functionality has been resolved. All systems are now operating normally.

Thank you for your patience.
Posted Jun 12, 2025 - 13:56 PDT

Investigating

We are currently observing partial disruptions in Notion’s functionality that may be related to a broader outage affecting Google Cloud Platform. Our team is actively monitoring the situation and will provide updates as more information becomes available.
Posted Jun 12, 2025 - 12:35 PDT
This incident affected: Notion Calendar and Notion Apps.