Notion Status

Some customers are experiencing errors while trying to login to Notion.

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 04:55 PDT

Investigating

The issue is being investigated by our team and we will update the page as soon as possible
Posted Mar 18, 2026 - 04:42 PDT
This incident affected: Core Product (Login and user accounts).