Some Plus plan customers are unable to access People Menu

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 16:08 PDT

Investigating

Customers on Plus plan with more than 100 members are unable to access People under Workspace settings.
Posted Jun 04, 2025 - 16:03 PDT
This incident affected: Notion App.