It has been resoled and Notion is back to normal.
Resolved
Monitoring
Our team is monitoring and investigating this
Identified
We have an outage issue and Notion is not loading