Notion Status

Delay in SIEM event processing

Incident Report for Notion

Resolved

This incident is now resolved.
Posted Feb 19, 2026 - 16:51 PST

Monitoring

Notion is experiencing a delay in SIEM (security webhook) event processing. Events will be emitted with no loss, but may be further in the past than normal (ie greater than 5 minutes). The system is beginning to recover and we will update when it has fully caught back up.
Posted Feb 19, 2026 - 14:15 PST

Identified

Notion is currently experiencing a delay in SIEM (security webhook) event processing. Events will be emitted with no loss, but may be further in the past than normal (ie. greater than 5 minutes).
Posted Feb 18, 2026 - 10:09 PST