Notion Status

Some custom agents may be delayed

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 09:05 PDT

Investigating

Some customers may experience delays with mail-triggered custom agent runs due to a temporary processing backlog
Posted Mar 17, 2026 - 08:56 PDT
This incident affected: Notion AI.