Notion Status

Database automations experiencing delays

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 11:16 PDT

Investigating

Database automations may be experiencing delays. Our team is investigating.
Posted Oct 27, 2025 - 09:38 PDT
This incident affected: Automations.