Notion Status

Inconsistencies in loading databases for some users

Incident Report for Notion

Resolved

Our engineering team has deployed a fix and our services are now operational.
Posted Aug 04, 2025 - 08:03 PDT

Update

We are continuing to investigate this issue.
Posted Aug 04, 2025 - 05:06 PDT

Investigating

Notion Databases may show inconsistencies for some users. We are investigating the issue
Posted Aug 04, 2025 - 05:04 PDT
This incident affected: Core Services (Databases).