Notion Calendar is down

Incident Report for Notion

Resolved

This issue has been resolved.
Posted May 19, 2025 - 17:21 PDT

Investigating

Notion Calendar is down. We are currently investigating this issue and will share any further updates
Posted May 19, 2025 - 16:45 PDT
This incident affected: Notion Calendar.