Notion Status

Images not displayed on Notion Sites

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 10:39 PDT

Investigating

We’re currently experiencing an issue where images are not displaying on public Notion sites. Our engineering team is actively investigating and working to resolve the issue as quickly as possible. We’ll provide updates as we learn more. Thank you for your patience.
Posted Jun 26, 2025 - 09:43 PDT
This incident affected: Notion Sites.