Notion Status

Failure to restore previous page versions

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Nov 22, 2025 - 13:31 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 22, 2025 - 12:36 PST

Investigating

Some users may face issues when trying to restore previous versions of their pages. The error may show "failed to restore version". Our team is actively investigating this.
Posted Nov 22, 2025 - 12:02 PST