Notion Status

Notifications are delayed

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 07:55 PDT

Investigating

We are currently experiencing an issue where notifications are delayed
Posted Jun 13, 2025 - 07:07 PDT
This incident affected: Notifications.