Notion Status

Operations such as duplicate a page or move a block

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 16:09 PST

Identified

We are experiencing an incident that affects operations such as duplicate a page or move a block, which started at 12:10pm PST.
Posted Jan 14, 2026 - 13:05 PST