Notion Status

Images failing to load for few users on android

Incident Report for Notion

Resolved

This issue has been resolved.
Posted Mar 19, 2026 - 13:24 PDT

Investigating

A few users have reported that images are failing to load on Android. Our engineering team is actively working to identify the cause
Posted Mar 18, 2026 - 23:43 PDT
This incident affected: Notion Apps.