Notion Status

Database automations will be experiencing some delays

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Aug 08, 2025 - 07:40 PDT

Update

We are continuing to investigate this issue.
Posted Aug 08, 2025 - 07:40 PDT

Update

We are continuing to investigate this issue.
Posted Aug 08, 2025 - 07:39 PDT

Investigating

We are currently experiencing an issue with database automations. Some users may experience delays.
Posted Aug 08, 2025 - 06:34 PDT
This incident affected: Automations.