Notion Status

Some database automations are delayed

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Oct 18, 2025 - 11:14 PDT

Update

We are continuing to investigate this issue.
Posted Oct 18, 2025 - 10:34 PDT

Investigating

Some database automations are partially disrupted. We are investigating the issue and are working to restore them.
Posted Oct 18, 2025 - 10:33 PDT
This incident affected: Automations.