Notion Status

Images failing to load for few users on Android

Incident Report for Notion

Resolved

This issue has been resolved.
Posted Mar 19, 2026 - 16:08 PDT

Monitoring

We're rolling out a fix for this issue and monitoring it closely.
Posted Mar 19, 2026 - 14:24 PDT
This incident affected: Notion Apps.