Notion Status

Database views on public sites impacted

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 16:08 PDT

Investigating

Database views on Notion sites hosted on custom domains are showing errors.
Our team is investigating the root cause and will share updates as soon as possible
Posted Oct 22, 2025 - 08:52 PDT
This incident affected: Notion Sites.