Notion Status

Delayed Database Automations

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 12:58 PDT

Identified

Database automations are experiencing some delays. Our team is actively resolving the problem.
Posted Aug 04, 2025 - 10:16 PDT
This incident affected: Automations.