Notion Status

Some Users are Unable to Access Notion

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 10:04 PST

Investigating

Some users may experience loading issues or errors when accessing Notion.
Our engineers are actively investigating this issue.
Posted Feb 26, 2026 - 09:36 PST