Notion Status

Notion export not working

Incident Report for Notion

Resolved

The incident has been resolved, and users should once again be able to use the export feature as normal.
Posted Sep 10, 2025 - 11:30 PDT

Investigating

When exporting a page or workspace, some users might notice that the export gets stuck. We are actively investigating this issue.
Posted Sep 10, 2025 - 10:26 PDT
This incident affected: Notion Apps.