Notion Status

Users can't see the "version history" option in the three-dot menu on the top right of a page

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 11:27 PST

Identified

We are aware that the option to see version history disappeared for some of our users. We identified the root cause, and a fix will be out soon.
Posted Dec 11, 2025 - 08:22 PST
This incident affected: Notion API.