Notion Status

Users cannot login to Notion using Login With Apple

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 13:18 PDT

Monitoring

Users were unable to login with Apple. We will continue monitoring in case more errors come up
Posted Jul 15, 2025 - 12:14 PDT
This incident affected: Core Services (Login and user accounts).