Notion Status

Some users may be experiencing issues loading Notion in their web browser.

Incident Report for Notion

Resolved

The incident has been resolved and the system is operational now.
Posted Jul 28, 2025 - 23:48 PDT

Investigating

We are currently investigating an issue where some users are unable to load Notion in their web browser.
Posted Jul 28, 2025 - 20:10 PDT