Notion Status

Customers in Korea may experience performance issues with loading.

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 08:01 PST

Investigating

We are currently investigating this.
Posted Nov 11, 2025 - 22:43 PST
This incident affected: Notion Apps.