Some users in Europe may not be able to access Notion.
Resolved·Partial outage
This incident has been resolved.
Tue, May 20, 2025, 12:06 PM
(11 months ago)
·
Affected components
Notion Apps
Updates
Resolved
This incident has been resolved.
Tue, May 20, 2025, 12:06 PM
Investigating
Some customers in Europe are currently experiencing loading issues with Notion. We are investigating the issue and will provide updates as soon as possible.