Notion Status

Exporting pages remains in a loading state for some users

Incident Report for Notion

Resolved

This issue had been resolved, Users should be able to export without concern.
Posted Dec 27, 2025 - 22:55 PST

Investigating

We’re currently investigating an issue where the export page function may remain in a loading state for some users and does not complete the export process.
Posted Dec 27, 2025 - 17:02 PST
This incident affected: Core Product (View and edit content).