Notion Status

Some language setting may experience issue on Notion desktop app on Windows

Incident Report for Notion

Resolved

This incident has been resolved! Installing the latest version(7.3.4) will resolve this issue.
Posted Feb 05, 2026 - 23:55 PST

Monitoring

We are aware issues that some users with some language setting may experience issue on Notion desktop app on Windows with page is in blank status and could not be loaded, our engineer team is actively investigating on this.
Posted Feb 04, 2026 - 18:49 PST
This incident affected: Notion Apps.