Notion Status

Some users are experiencing slow exports

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Apr 04, 2026 - 08:19 PDT

Monitoring

We have mitigated the issue and are continuing to monitor it closely.
Posted Apr 03, 2026 - 23:24 PDT

Investigating

We are currently investigating this issue.
Posted Apr 03, 2026 - 19:05 PDT