Notion Status

Some users may be experiencing an intermittent something went wrong error when accessing a notion page

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 18:03 PDT

Identified

We have identified an issue where some users get a something went wrong error and we believe we’ve found the root cause and are validating our fix
Posted Apr 07, 2026 - 16:36 PDT