Notion Status

Some users are facing stale workspace billing information

Incident Report for Notion

Resolved

This issue is now resolved.
Posted Mar 09, 2026 - 15:04 PDT

Update

Some users are facing stale workspace billing information and highly recommend to hard refresh(Cmd/Ctrl + Shift + R) or clear their cache.
Posted Mar 08, 2026 - 21:18 PDT

Monitoring

Try to re-log in and hard refresh(Cmd/Ctrl + Shift + R) the workspace.
Posted Mar 08, 2026 - 18:50 PDT

Investigating

We're currently investigating workspaces where paid plans got downgraded. Please hard refresh(Cmd/Ctrl + Shift + R) the workspace in the meantime.
Posted Mar 08, 2026 - 17:44 PDT
This incident affected: Notion Apps.