Notion Status

Users are unable to embed published notion sites pages into other platforms

Incident Report for Notion

Resolved

This issue has been resolved
Posted Feb 12, 2026 - 09:52 PST

Investigating

We are currently investigating this issue.
Posted Feb 12, 2026 - 03:28 PST
This incident affected: Notion Sites.