Notion Status

Notion Web Clipper is not working for some users

Incident Report for Notion

Resolved

This incident has been resolved, we fixed the issue.
Posted May 20, 2025 - 20:14 PDT

Update

We are continuing to work on a fix for this issue.
Posted May 20, 2025 - 20:13 PDT

Identified

We have identified the root cause, and now we are working on a fix for this issue.
Posted May 20, 2025 - 14:38 PDT

Investigating

We are investigating an incident where some users are getting a "Please go online to save to Notion" error when accessing Notion Web Clipper.
Posted May 20, 2025 - 13:48 PDT
This incident affected: Notion Apps.