Notion Status

Some users are experiencing slow sign-ins when logging in with Google

Incident Report for Notion

Resolved

The issue has been resolved. Login with Google functionality has been restored.
Posted Sep 18, 2025 - 09:12 PDT

Investigating

We are currently investigating the issue.
Posted Sep 18, 2025 - 08:57 PDT
This incident affected: Core Services (Login and user accounts).