Notion Status

Database automations are currently experiencing delays.

Incident Report for Notion

Resolved

This incident has been resolved, database automations are now fully functional.
Posted Oct 27, 2025 - 23:49 PDT

Investigating

Database automations are currently experiencing delays.
Our engineering team is actively investigating the issue. We’ll provide updates as more information becomes available.
Posted Oct 27, 2025 - 17:54 PDT
This incident affected: Automations.