Resolved
This incident has been resolved. Logged-out users who open a Notion page link should be prompted to the login page correctly.
Investigating
We’re investigating an issue where logged-out users who open a Notion page link may see a blank page instead of the login prompt. As a workaround, sign in at notion.so/login, then reopen the page link. We’ll share updates as we learn more.