Resolved
Between 8:22pm and 8:54pm PST Notion experienced a network issue which prevented some users from connecting to the service. The issue has been resolved and we are investigating to determine the root cause.
Investigating
Notion is currently experiencing network issues. We are investigating and will share further updates.