Subscribe to updates
Powered by
Terms of service
Customers in Korea may experience performance issues with loading.
Resolved
·
Degraded performance
This incident has been resolved.
Thu, Nov 13, 2025, 04:01 PM
(
8
months ago)
·
View all updates
Affected components
Nov 12, 2025, 06:43 AM
Nov 13, 2025, 04:01 PM
Notion Apps
Updates
Resolved
This incident has been resolved.
Thu, Nov 13, 2025, 04:01 PM
Investigating
We are currently investigating this.
Wed, Nov 12, 2025, 06:43 AM
(
1
day earlier)
Customers in Korea may experience performance issues with loading. - Notion Status