No components marked as affected
Resolved
A small number of users may have experienced higher latency or intermittent failures. This has now been resolved.
Investigating
Some users may experience issues when accessing Notion.Our engineers are actively investigating this issue.