Resolved
This issue has been resolved and images should be loading normally on all clients.
Investigating
We are currently investigating an issue affecting image delivery in our production environment. Starting at approximately 6:04 PM PDT on August 3rd, 2026, customers are unable to load images.
Our engineering team is actively working to identify and resolve the root cause. We will provide updates as we make progress toward resolution. Thank you for your patience.