Resolved
We've implemented a fix for the issue where duplicating a Notion Sites page "as a template" could fail with a "This page couldn't be found" error. All affected services are now operating normally.
Identified
We're investigating an issue where duplicating a Notion Sites page "as a template" can fail and show a "This page couldn't be found" error.
Our engineers are working to ship a fix and will share another update once it's deployed.
If you hit this issue, try changing the URL host from "app.notion.com" to "notion.so" and then duplicate again.