Resolved
We implemented a fix for the issue causing some published Notion site homepages to fail to load and have monitored the service to confirm recovery. All affected services are now operating normally.
Identified
We have identified an issue where some published Notion sites fail to load their homepage. Our engineers are working to mitigate the issue and we'll share any further updates.
Investigating
We're investigating an issue where some published Notion sites fail to load their homepage. Our engineers are actively investigating this issue and we'll share updates as we learn more.