This incident is now resolved.
Resolved
Monitoring
This issue has been mitigated and we're monitoring.
Investigating
We are experiencing high latency with login, adding users to workspaces and saving edits for now.